Chrysler 300 forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. Chrysler 300 Electrical Problems and Questions
    So I have no clue about any of this. My passenger side headlight is out and I remember someone telling me to always check the fuse first because it could be a cheap easy fix. I’ve looked at the fuse box and for the life of me cannot find the fuse for the headlight. I’ve looked at the diagrams...
  2. Chrysler 300 Electrical Problems and Questions
    My 2015 Chrysler 300 S front fuse box cover doesnt seem to match up to what is actually there. Its mainly the relays that seem out of place. There are slots that say spare but if you pull them, things stop working or turn off. does anyone have a 2015 that can take a picture of and send to me...
  3. Chrysler 300 Electrical Problems and Questions
    When I start my car and take off the lights come on fine, but by the time I get out the driveway and a few houses down, my head lights go out. The hazards and break lights still work. Since both lights go out I am thinking it is a fuse. Could it be anything else?
  4. Chrysler 300 Performance Mods - Engine - 3.6L V6
    Which fuses control the Headlights and Backup lights on my 2010 300 Touring Model. They keep going out.
  5. Chrysler 300 Electrical Problems and Questions
    I have a 2014 Chrysler 300C with about 60xxxkm on it. In the past 3 or 4 months the battery will die over night or over a couple nights. The cluster screen shows white and the gauges act all strange and it will barely have enough juice to start or it wont start at all. The other day I decided to...
  6. Newbie Check In!
    New to this site and I hope it can help me. Like when I actually have money to make mods. I just bought a 300c two months ago and I have been loving it. I came here with a question though. While I was out driving when my stereo (Panasonic AVH-P4100DVD) just shut off. The fuse seems fine (#36 in...
  7. Chrysler 300 Electrical Problems and Questions
    Hi everyone! I tried searching the forums for an answer to this issue however I didn't find any matches to my search that dealt with this issue, so I'm asking for your help if you know how to fix this issue. My 2008 Chrysler 300 LX uses the traditional ($250.00 - ouch! I remember the days when...
1-7 of 7 Results
Top