Chrysler 300 forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi, Back on 8/24/2021 my car attempted to start and a christmas tree of lights came on. The car then was a no start for 10 minutes. The car was taken to Autozone to get the code and it mentioned BCM. I was able to get it into the dealership and it sat for 3 days with nothing done (they wanted to recreate the problem). On 9/4/2021 while driving 1.5 miles from starting the car started the same christmas tree of lights, windshield wipers going off, bucking, shifting down and braking on me. Got pulled over off road, shut car off, no start for 10 minutes. Started it and got it home. Due to holiday got it back to dealership on 9/7/2021. Car sat there until 9/20/2021 trying to recreate problem. I got Chrysler involved and this car is now a STAR case. Engineer came to dealership and told them to check grounds. They found a star ground that was a little corroded. They didn't know what else to do and thought it was all gravy. Dealership told me not to shut off car if it did it again. Picked up car 9/20/2021. On 9/27/2021 started car made it about 50 feet, started doing the good old freak out and it was more aggressive than originally. Got it to my doctor appointment calling dealership on the way a few miles down the road. They picked up car and got the codes. Of course they removed the codes, told me mechanic not in and Tuesday would be busy. They have been MIA ever since on getting back to me. I literally don't know what to do anymore. This car is also under a Lifetime Warranty, 177k highway miles, 1 owner. I attached the codes with date comparison when they happened. HELP! Anyone else seen this happen?
 

Attachments

1 - 1 of 1 Posts
Top