Chrysler 300 forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter · #1 ·
I have the HEMI and for some reason my car will just die occasionally and for no apparent reason. For instance yesterday after driving for over 30 min. I came to a stop in a parking spot and DEAD, only thing on the dash is the oil light. It happens also after I fill up my tank, I can be stopped or going 25 MPH and the engine will just die. It happens only 1-2 times a month. Told my local chrysler dealership about it and they said they never have heard about 300c doing this. Any ideas??
 

·
Registered
Joined
·
1,475 Posts
Sorry about your troubles..never heard of this but it did happened to me when I used to have my 1991 Bonneville SSE. While on highway crusin' 120 kph (75 mph) or just by crawling through traffic stops, the engine dies and all of my power options are dead.

They had replaced my computer module ($500!).
But let's wait maybe someone might chime in with this issue and advised.
 

·
Registered
Joined
·
1,056 Posts
the oil? or oil pressure? i believe the car will die if the oil pressure gets to a certain point. I saw your post awhile back about topping off and the car dying. I believe there is a TSB on that one. there are a lot of folks that has happened to. If it is the check oil pressure light and that is coming on and your car is dying, that is serious.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #4 ·
EEEK! What should I do about getting this looked at? Do you think its the oil pump?
 

·
Registered
Joined
·
1,056 Posts
Who knows... Maybe. From the research I've done it's a vast array of potential issues from as small as an oil change fix to a crack around the sensor. If you can do it yourself check and see if there leaks around the sensor. Sending unit could be bad also. Did you check your engine oil level? Could be low as was in my case... REAL low.

But as checkx6 warned me, I'll encourage you to get on it fast. You're looking at potentially major issues. Don't wait on it.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #6 ·
I will check ASAP, what type of oil do you use?? I called my local chrysler dealer and they said the oil light stays on when the engine stalls......should I trust that?
 

·
Registered
Joined
·
1,056 Posts
I will check ASAP, what type of oil do you use?? I called my local chrysler dealer and they said the oil light stays on when the engine stalls......should I trust that?
i use 0W40, what is recommended for the SRT


i dont know what is for the 5.7. regardless, so you are saying that you fire it up, drive down the road and it shudders then shuts down?

do you get any lights coming on before hand? can you take a pic of the light that comes on. there is an Oil Pressure light on the lower left hand side of the dash. that is what im referring to. Do you have a Predator? If you can, take it over to Autozone and see if it is throwing any codes.


if we can see the codes we can get a better idea of whats going on.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #8 ·
i use 0W40, what is recommended for the SRT


i dont know what is for the 5.7. regardless, so you are saying that you fire it up, drive down the road and it shudders then shuts down?

do you get any lights coming on before hand? can you take a pic of the light that comes on. there is an Oil Pressure light on the lower left hand side of the dash. that is what im referring to. Do you have a Predator? If you can, take it over to Autozone and see if it is throwing any codes.


if we can see the codes we can get a better idea of whats going on.





I literally just purchased my predator today, it doesn't shutter at all it just dies. There is never any check engine or any lights that go on. I read that it could be something wrong with my fuel tank, it could be running rich.
 

·
Registered
Joined
·
1,056 Posts
hmmm. If you have the predator go out and find out if she is throwing a code. If you dont, run over to AutoZone, they do it for free.

i mean literally could be a myriad of issues, hard to say with the details we have. I mean honestly fuel and spark make the thing go... i read where you were having issues back in Dec after you topped off. I swear i read somewhere that this was a big issue with some 5.7s in general. I mean could be your fuel pump.

go to autozone see if its throwing a code.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #10 ·
I will thanks for the info, gotta wait till my predator gets shipped
 

·
Premium Member
Joined
·
9,197 Posts
My 3.5 would just suddenly die, usually when the engine was cold in the first 15 minutes from start up. It was the crank sensor. On the final day before it quit completely it was running terrible. I barely made it to the dealership.
 

·
Registered
Joined
·
3 Posts
That is actually what mines been doing. I filled up today and it did it also. But as I recall its has been the last few time also.....
 

·
Registered
Joined
·
3 Posts
My car has been doing the same thing. But today it died at 60 mphs. I did fill it with gas. And it happened anp0other time that I know I had filled it. Figure it out yet.
 

·
Registered
Joined
·
164 Posts
I have read that if you keep putting gas in after the first time the gas pump clicks off and you keep topping it off that the car might die. I have never had this happen to me, but I read it before I needed a fill up and I did not try to top it off.
 

·
Registered
Joined
·
9 Posts
I had a similar problem with my hemi in Dodge truck. Sounds weird but check your transmission fluid level. Mine was not even registering on the stick. Put several quarts in and no more problem. May not be it, but won't hurt to check.
 

·
Registered
Joined
·
17 Posts
Well this just happened to me today! 2006 5.7 122k and never had any problems.

AND! I just topped off the tank. Had a little under 1/2, and the station I always use was out of regular unleaded, and the manager was putting signs on all the pumps that they were selling 93 octain Premium for the regular price! so I filed it up. SO about 50/50 mix, making it a mid-grade.

Got 1 mile down the road and when I went over a small hill the engine just turned off, and the only light on the dash if I remember right was the oil light was on. Didn't think much about that at the time - but shouldn't ALL the idiot lights be on? Is this an indication that it cut off because of a low oil pressure indication?

Well I pulled over (neighborhood road) and turned it off, and it tried to restart but faltered and quit. So I waited about 3 minutes and tried again and it started. I got up to 30 so I could coast it home if it quit again, and it did right as I made the turn into the driveway.

Let it sit for about 45 minutes, it started right up. Ran about 3 minutes then just quit again. Falter on restart, waited 1 minute, then it started but idle speed fluxuated, then went to 1500, then settled down, slowly going to about 600. I wondered if I hit a bump and it quit, or if turning made it quit. So, sitting in the seat, I rocked the car that it immediately quit. However, after restarting again, I could not duplicate that, but it quit again on it's own. :(

Tomorrow I will have the oil pressure displayed as it is running to see if it goes low and makes it quit. Like someone said - bad sensor? Computer? Bad fuel pump?

One thing I did notice that I have not heard this noise before is a ticking noise from the center consol, and wondering if the black box is going bad - would that make the car quit?

Any other ideas?

Edit - I found another thread - "Stalling problems after filling up" that I am going to copy this to - please answer there as I will post what I find there
 

·
Registered
Joined
·
8 Posts
I know exactly what it is: Chrysler has a recall but they are not admitting all the cars yet. Basically not enough people know where to complain. A class action suit was just recently done for other models for same problem. My chrysler 300 does the same. So dangerous bc we can get rimmed from behind at a light when we are abt to drive and then stall. Go to the following site. It will explain the law suit and it's VERY important u make a complaint with ALL 3 links they have at the end. Only if we stick together will.something happen. http://www.chryslerproblems.com/tr ends/tipm/ 1. CarComplaints.com 2. Notify Cas 3. Report a safety to NHTSA*. Very important!!!*
 

·
Registered
Joined
·
23 Posts
sounds like you've got the gas tank rollover valve recall problem.
check with your dealer for tank availability ,they'll get a tank and replace it under the recall issued last year.
 

·
Registered
Joined
·
249 Posts
The problem is known at the dealership as X53. Call them, tell them you have the dreaded X53 problem and your call stalls when you fill up the tank. Confirm the service is under warrantee and free. ask them to order the fuel tank and give you an ETA. they will tell you it is back ordered without an ETA. Post your findings here. You're not alone. Sadly.

http://www-odi.nhtsa.dot.gov/owners/SearchResults;jsessionid=Jitr36JpXhYxupgKZV3Wrl2cjq89cH2966m1I4J8l_Zc-Hk50M8j!-281605258?prodType=V&searchType=PROD&targetCategory=A&searchCriteria.model=300C&stats=222017%2C1%2C3%2C494%2C4%2C300C&makeStats=&jsonBaseURL=%2Fdownloads%2Ffolders%2F&searchCriteria.model_yr=2006&searchCriteria.make=CHRYSLER&searchCriteria.prod_ids=222017
 
1 - 20 of 22 Posts
Top