Chrysler 300 forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Recently came into an 06 300 touring. My wife loves the car but cannot figure out why the lights flicker on and off. Also having issue with dash lights dimming. Please shoot me in the right direction. Thanks
 

·
Premium Member
Joined
·
34,044 Posts
Welcome to the forum! I moved this to the Newbie Section, since it is your first post.

Not sure what this problem is caused from..perhaps the battery? Hold tight, somebody should come up with the answer here for you. Enjoy the site!
 

·
Premium Member
Joined
·
19,192 Posts
hmm i am lost myself...do you have aftermarket HIDs installed? also does this only happen in automatic mode or when you manually turn the headlights on? i am trying to gauge if your light sensor is bad...
Also welcome from Michigan!
 

·
Registered
Joined
·
5 Posts
FIRST!! take that back to the dealer and have some professional check it out. not saying that the people here don't have great knowledge cause they do, but they cannot guarantee your warranty like your dealership can. 1st stop dealer, next stop forum.
 

·
Registered
Joined
·
6,406 Posts
FIRST!! take that back to the dealer and have some professional check it out. not saying that the people here don't have great knowledge cause they do, but they cannot guarantee your warranty like your dealership can. 1st stop dealer, next stop forum.
If everyone took their car to the dealer the first sign of trouble, you'd have a lot of broke Chrysler owners...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #12
my relay #36 under the hood that controls parking lights is cycling on and off, where is the light sensor (middle of the dash), and has anyone had problems with their actual headlight switch
 

·
Premium Member
Joined
·
34,044 Posts
my relay #36 under the hood that controls parking lights is cycling on and off, where is the light sensor (middle of the dash), and has anyone had problems with their actual headlight switch
Switches have been a problem on some models. If you do a search, you may find some related issues..here is an example.

Headlights go on when they want....


If you car still has warranty, take it in and they will replace it.
 

·
Registered
Joined
·
9,721 Posts
Good to have you online with us here on the Z!!! Haven't had any issues with my ride's lights flickering, so not too sure. Hope you get it resolved quickly. Enjoy the forum...

 

·
Registered
Joined
·
8,535 Posts
Welcome to the 'Z', from Virginia. You may also want to check out the lights fuse.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #16
unplugged the switch and the lights are on full time with no flicker. i have a local pick and pull that has a switch so wish me luck
 

·
Registered
Joined
·
1 Posts
Anyone find an answer

i have been having the same problem with my 300. And i did the same i pulled the switch on it. i think its the switch but i dont know and up here in Toronto the switch is on back order for 6 months. So by all means if anyone knows how to fix this let me know. im going to go out now and see whats up with relay #36 like someone said but im sure it will do nothing.
 
1 - 20 of 22 Posts
Top