Chrysler 300 forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello All!! I have a strange question. I bought a 2011 C AWD at 48K for miles and now have 75k. The vehicle came with the clad chrome 18" wheels on it with decent Michelin tires. Car drove fine. Over the last 5000 miles I have had the entire PowerTrain replaced at chryslers expense. I have also had two sets of tires put on this vehicle in the last month to try and remidy the problem. I can't seem to rid the Bounce/Hop/Shimmey I have in the vehicle this is how it occurs.

bounce/hop is only present on concrete, and at speeds over 68mph. Blacktop is smooth, but.......

shimmy is at 47-63mph. Sometimes in the steering wheel and sometimes in the rear of the car, pending the road surface. But it happens on all roads.

The car also rides like crap!! It feels like my tires are stone, and the car was dropped from 50 feet when I hit normal road wear.

The dealer said that it's because of the improper rims being installed, can this really be the issue?? The vehicle didn't do this before. 2 brand new top end Michelin tire sets and tons of alignments and balancing?? I need to figure this out and soon. PSI is set for the recommended 30PSI. Michelin Primacy MXM4M 225/60/18. Chrysler is aware of the 18" runs being on here and corporate offices said it was just fine to have them on. I really don't know how the rims could affect the car but who knows. And no they are not bent, checked that already! Thanks for any help and advise on this issue.
 

·
Registered
Joined
·
10 Posts
sounds like you have something similar to the jeep world as "death wobble"? I would check all suspension and steering components for excessive wear. this may take another person to help. check steering/alignment components first then move to control arms and ball joints
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I thought of that as I did own a jeep before. I had 3 different shops including my dealer check all my suspension components. All have said everything is well and in place.

I have noticed that when I do hit a bump, that the car does not just go over it smoothly. I seem to get and after effect of a few more continued hops/bounces. Is that indicating a worn or wearing strut or shock??
 

·
Registered
Joined
·
10 Posts
struts and shocks will give you a repeated bounce it they have failed... go up to the car and push down as hard as you can on each corner. if it "bounces" more than once that may be your problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I tried that again and they are stiff but go down and up and just a slight second bounce. It really didn't seem to bad, but could that be the failing suspension? What would you suggest for front struts and rear shocks? I am just looking for a cheaper long lasting good ride. And if I can only do the front or rear first, which would you recommend? Thanks everyone. (We did fully rule out the tires and rims for sure today.). Although, I have to take the tires in for warranty replacement as we found siping that is uneven in large parts of 2 tires. Crazy. Never had bad luck with Michelins until now.

M
 
1 - 5 of 5 Posts
Top