Hey guys

Discussion in 'Newbie Check In!' started by bossladee, Feb 10, 2018.

  1. bossladee

    bossladee New Member

    Joined:
    Oct 11, 2017
    Messages:
    5
    Likes Received:
    0
    Gender:
    Female
    Location:
    winchester va
    Vehicle:
    300
    Vehicle Yr:
    Gen1 - 2005
    Trim?:
    300
    Color?:
    Custom
    Hey guys I'm a proud owner the 05 base 2.7 and 06 3.5 I love my 300's
     
  2. jkelly16

    jkelly16 Aww Peg! Administrator Moderator

    Joined:
    Sep 18, 2011
    Messages:
    141
    Likes Received:
    32
    Gender:
    Male
    Location:
    Clayton, NC
    Vehicle:
    Challenger
    Vehicle Yr:
    Gen1 - 2009
    Color?:
    Custom
    Welcome to the Z from NC! Glad you joined, enjoy the site!
     
    bossladee likes this.
  3. RGV06ChryslerTouring

    RGV06ChryslerTouring Member

    Joined:
    Nov 10, 2014
    Messages:
    546
    Media:
    1
    Likes Received:
    33
    Gender:
    Male
    Location:
    Rio Grande Valley
    Vehicle:
    300
    Vehicle Yr:
    Gen1 - 2006
    Trim?:
    Touring
    Color?:
    Brilliant Black
    Welcome to the forum!
     
    bossladee likes this.
  4. weldon

    weldon New Member

    Joined:
    Feb 12, 2018
    Messages:
    9
    Likes Received:
    1
    Gender:
    Male
    Location:
    GA
    Vehicle:
    300
    Vehicle Yr:
    Gen1 - 2007
    Trim?:
    300C
    Color?:
    Brilliant Black
    That should twice the fun!
     
  5. Schom300

    Schom300 New Member

    Joined:
    Feb 11, 2018
    Messages:
    2
    Likes Received:
    0
    Gender:
    Male
    Location:
    Minnesota
    Vehicle:
    2005 Chrysler 300 Touring
    Vehicle Yr:
    Gen1 - 2005
    Trim?:
    Touring
    Color?:
    Cool Vanilla
    Hey everyone, I have a problem with my 05 300. So my oil change was at 4,500 miles. Just changed it with Castro synthetic, but I have what sounds to be a dry/sticky lifter. The car runs and drives like nothing is wrong untill it’s idleing at 0 mph in drive or reverse, that’s when th knocking starts. Any common problems I can watch for? I’ve included a video I took of the knocking. Thanks for the help in advance. Matt
     

Share This Page