Chrysler 300 forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Took the 300 to the driving range with the kids. Went to leave and the car wouldn't start. 2008 Limited 3.5. I had the car running on the auto start before I got in the car, maybe 5 minutes or so. As I'm walking to the car, I hit the auto startto turn it off meant to hit the trunk key. Anyway, I load the car, and then it won't start. It won't turn over, and I can't even put the windows up. Very strange. I'm not a mechanic, but it would seem to me it's either an electrical problem or the engine. If the engine, then why would I not be able to put the windows up? I guess it's possible it's something as simple as a fuse, but I doubt it. I've had weird electrical problems in the past, but I'm just hoping the engine didn't go bad. I checked the oil and it was low, but I've noticed nothing out of the ordinary, such as knocking, etc. Does this sound like something you've heard before? I had it towed to the dealer. We'll see what they say. Until then, I'm pretty paranoid. When I bought this, there were many red flags about the engine. I have a "lifetime" warranty on the powertrain, but why does that not make me sleep better?

Any help and/or insight is appreciated.
-JR
 

·
Registered
Joined
·
1,068 Posts
I'm gonna say security issue over engine problem. With all the computer bullshit these cars have, one little step out of the ordinary and the damn thing shuts down
 

·
Registered
Joined
·
1,032 Posts
It definitely is related something electrical....if your engine goes it still doesn't stop you from gaining accessory power to raise up your windows......I think that something is haywire with your alarm and causing this issue.
 
1 - 3 of 3 Posts
Top