Chrysler 300 forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
This is my first post here. I have searched everywhere and cant seem to find an answer. I have a 2007 300c and I just replaced the factory cd with aftermarket Kenwood DNX 8120. I have the csw-jack, the swi-can2 and the c2r-chy interfaces to allow me to keep my display and factory steering wheel controls. I cant seem to get the thing to work on my display over the steering wheel. It does not show the compass anymore and also says FM 00.0. Have I wired something wrong? Thanks in advance.:4-dontknow:
 

·
Premium Member
Joined
·
7,746 Posts
only thing i can say is pm blowndakrt he maybe able to help you, as he is our resident audio expert
 

·
Registered
Joined
·
973 Posts
You will not get the display to show radio stations with an aftermarket headunit. But the compass should still be up there. The only way I know of to get rid of the FM 00.00 is to remove the factory amp.

What is the display showing now? You might just need to go through the different display features to get it set up again to your preferred setting.

Are the steering wheels controls working?

Shawn
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Blowndakrt,
That answered my question about the FM00.0. Thanks. My Compass now works as well, I guess you have to have the entire center console plugged back up for it to work. Thanks for the help guys.
 

·
Registered
Joined
·
310 Posts
did u have to remove the amp then? doesit sound ok anyway? i am thinking of buyiing the same unit...i have 2007 300 touring signature series with the nav and boston acoustics
 

·
Registered
Joined
·
973 Posts
did u have to remove the amp then? doesit sound ok anyway? i am thinking of buyiing the same unit...i have 2007 300 touring signature series with the nav and boston acoustics
You are not required to remove the stock amp. Removing the stock amp is what will get rid of the FM 00.00 message in your EVIC. So it depends on how important is to the individual to not have that message displayed in your EVIC. If you remove your stock amp, you will need to run separate amps for your car. The aftermarket head units can not run all 6 or 8 speakers in the Boston equipped car. You would only be able to run 4 of those speakers.

Shawn
 

·
Registered
Joined
·
973 Posts
cool thanks since i dont have evic on mine
Since you don't have the EVIC, I wouldn't worry about it then. You will be fine with keeping the stock amp. You will need the PAC piece C2R-CHY harness to integrate the aftermarket headunit into the factory amp.

If you want to keep steering wheel controls you will also need the SWI-CAN or the SWI-CAN2, (it list both as combatible) and the SWI-K for the kenwood radio. Its listed as the SWI-JACK, but the J is for JVC, A is for Alpine, C is for Clarion, and K is for Kenwood.

Shawn
 
1 - 11 of 11 Posts
Top