Chrysler 300 forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I own a 2014 300 S 5.7 and I’m working on blacking it out. I’ve already got the Hemi badges and have seen a bunch of users on here have swapped the wing emblems but I can’t find any black ones that aren’t outrageously priced. If anyone knows where to get some cheaper please let me know! Also if anyone knows where I can get a black 300S badge for the trunk lid that would also be great!
 

·
Registered
Joined
·
1 Posts
Hi everyone. New to this forum. Looking for some help in diagnosing an issue with son's 2011 Chrysler 300 5.7 hemi. Have heard many possible conclusions but hoping its not the worst. The car has 120k miles bought used w/100k already. Recently has been running rough when accelerating and light comes flashing. OBD is shown various codes from random misfires and cylinder 3 misfire, oil sensor codes. Have heard anything from bad plugs to cam lifters bearing ceasing and gouging cam. You're thoughts and suggestions are welcome!
 

·
Registered
Joined
·
207 Posts
Hi everyone. New to this forum. Looking for some help in diagnosing an issue with son's 2011 Chrysler 300 5.7 hemi. Have heard many possible conclusions but hoping its not the worst. The car has 120k miles bought used w/100k already. Recently has been running rough when accelerating and light comes flashing. OBD is shown various codes from random misfires and cylinder 3 misfire, oil sensor codes. Have heard anything from bad plugs to cam lifters bearing ceasing and gouging cam. You're thoughts and suggestions are welcome!
You'd probably be better off putting up your own post in Mechanical Problems and Questions, rather than piggybacking on someone else's topic on Custom Exterior Modifications.
 
1 - 3 of 3 Posts
Top