Chrysler 300 forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hello everyone. I have a 2012 Chrysler 300C. Today, my key remote unlocked the car just like normal. When I got in the car, the dash said something about the key fob (it was not lit up and very faint). I pushed the button to start the car and nothing happends. No dash lights. No power to the door locks and trunk. It's like car doesn't have a battery (it does). I pushed the unlock button on the keyfob and a clicking happens under the hood and won't go away until I pull the 20 amp horn fuse (fuse number 11).

I pulled the negative from the battery for about 30 minutes, reattached, and still no power.

I would appreciate your advice.

Edit: hooked up jumper cables to another car and nothing. It's like the car doesn't have a battery.
 

·
Registered
Joined
·
518 Posts
Hello everyone. I have a 2012 Chrysler 300C. Today, my key remote unlocked the car just like normal. When I got in the car, the dash said something about the key fob (it was not lit up and very faint). I pushed the button to start the car and nothing happends. No dash lights. No power to the door locks and trunk. It's like car doesn't have a battery (it does). I pushed the unlock button on the keyfob and a clicking happens under the hood and won't go away until I pull the 20 amp horn fuse (fuse number 11).

I pulled the negative from the battery for about 30 minutes, reattached, and still no power.

I would appreciate your advice.

Edit: hooked up jumper cables to another car and nothing. It's like the car doesn't have a battery.
Welcome, Brian.

Start by checking fuses 2 and 4 in your rear PDC. They are 60A yellows and feed your front TIPM, so not much will work without them.

Good luck!
 
1 - 2 of 2 Posts
Top