Chrysler 300 forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2007 Chrysler 300 3.5l (not sure if engine size matters) but the radio screen is blank and the only thing that works is the on/off/volume and the station preset buttons on the left. This morning however I went out and started the car and the screen was on, all the buttons worked and then 15 minutes later it was off again. Anyone have any ideas?
 

·
Registered
Joined
·
1,316 Posts
Does it still work other than the lights being out and the buttons not working? Can you still get a station, cd work, change stations, stuff like that?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yes the cd works and i can hear the stations, also the preset station buttons work but no screen or lights and the other buttons don't work either, like the am/fm and all the other don't work
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Nope it's was blank like that when i got it used (the car) but, it did the same thing again this morning when i started it up the screen came on and i was also able to eject the nav disk, however as soon as i touched the seat warmer button it went back out. Since the car hadn't yet warmed up i turned it off again and still no screen when i turned it back on, i was thinking maybe some kind of short but i don't know where to start looking. especially since when it came on yesterday it didn't go off again when i hit the seat warmer button. other than gettin' a new radio any other ideas?
 

·
Registered
Joined
·
11 Posts
hi my 300c crd done 146000 and today the screen went blank got sound and play cd unpluged and put back in worked ok for bout 20min then went blank.any ideas thanks john,uk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Yeah it happened again this morning. I got in the car and at first it the screen didn't come on, so I turned the powr off and right back on and the screen came on. This time I DID NOT turn the heat on or the seat warmers just in case that's what caused some kind of a short and, I drove about two blocks and the screen went out again. Just to recap, the station preset buttons work and so it will load a cd, but nothing else works when the screen goes blank.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Checked everything including the fuse and replaced that, now the radio is stuck on AM, I need some serious help so that I won't have to go out and rob a bank or something for a new radio...lol (disclaimer:I will not really rob a bank). But this is driving me crazy because I bet anything that it's something simple. I've disconnected the radio plugs, reseated them, and then got the radio to turn back on but now it's on AM like I said. and it's still only the cd player, the volume button, and the preset buttons that work.
 

·
Registered
Joined
·
1 Posts
Need help my chrysler 300 radio screen is blank and stuck in am mode. Had to replace alternator and battery. Now my radio is acting funny any help please.
 
1 - 11 of 11 Posts
Top