Chrysler 300 forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
221 Posts
Discussion Starter · #1 ·
Today when I was on the highway, my car randomly died and then came back within 2 seconds. All electronics shut off while it was off(radio, air, dash), and when it came back on all the dash lights came on like they do when the key is in the "on" position. I was going about 75mph when it happened the first time and it happened while I passed under a bridge, so I thought maybe it was a spook thing.

Then it came back again about 15 miles later down the highway when I was going around 65mph(construction zone). Same exact thing, came back right away.

Only happened those 2 times, on my way to school to get a parking permit for the lot there. On my way back home (about a 40mi drive) it was fine, no problems at all.

Any ideas what could have or is going on to cause something crazy like this?
 

·
Registered
Joined
·
1,175 Posts
That's really odd, I haven't got a clue what it could be but I would suggest a visit to the dealer or a reliable garage if you know one.

Probably shouldn't wait too long to get this checked out...
 

·
Registered
Joined
·
221 Posts
Discussion Starter · #6 ·
I actually was thinking about the PCM thing. I pulled fuse 11 for a minute then stuck it back in today.

How can I check my battery? I've heard stories about auto parts stores not knowing what they're doing and it isn't an accurate test. Car starts up fine, but that's all I know
 

·
Registered
Joined
·
51 Posts
Mine did this but just my electronics (Dash, radio etc) turned off not the engine still pretty freeky though. I remeber reading somthing about the pcm connector becoming corroded after time but i just got a new battery and pulled fuse 11 and so far it hasent done it again.
 

·
Registered
Joined
·
55 Posts
mine did the same thing about three years ago while i was merging onto the hwy.i took it to the dealer they put a scan tool on it and got a bunch of strange readings.but it has never done it again.the blamed it on the 22" wheels.
 

·
Registered
Joined
·
221 Posts
Discussion Starter · #9 ·

·
Registered
Joined
·
51 Posts
def. i have 2 batterys with my system and one is a yellow top. these cars are really sensitive about anything in the electrical in my experience with it. idk what wheels would have to do with it i avoid mechanics as much as i can lol
 

·
Registered
Joined
·
51 Posts
mine did the same thing about three years ago while i was merging onto the hwy.i took it to the dealer they put a scan tool on it and got a bunch of strange readings.but it has never done it again.the blamed it on the 22" wheels.
thats when mine did it lol thanks god it was just the elct not the engine but i lost gauges and everything just went nuts
 

·
Registered
Joined
·
1 Posts
Today when I was on the highway, my car randomly died and then came back within 2 seconds. All electronics shut off while it was off(radio, air, dash), and when it came back on all the dash lights came on like they do when the key is in the "on" position. I was going about 75mph when it happened the first time and it happened while I passed under a bridge, so I thought maybe it was a spook thing.

Then it came back again about 15 miles later down the highway when I was going around 65mph(construction zone). Same exact thing, came back right away.

Only happened those 2 times, on my way to school to get a parking permit for the lot there. On my way back home (about a 40mi drive) it was fine, no problems at all.

Any ideas what could have or is going on to cause something crazy like this?
Did you ever figure out why mine just did the same today
 
1 - 14 of 14 Posts
Top