Chrysler 300 forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, I'm stumped on what's causing my power steering whine.

I changed the high pressure line from the pump to rack, new pump, feed line to pump, and put in a new resevoir.

I swapped out 32oz of fluid with Valvoline ATF+4.

At idle it sounds like a meat saw. clip of car running.

Any ideas on what to do next?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
The loud whine in the video is separate from the power steering whine. The noise sounds like it's coming from the driver's side.

Also I think it's not charging all the way. Attached 2 pictures of voltage reading at different rpms.

Idler, tensioner, water pump, and power steering pulleys were replaced.
 

Attachments

·
Registered
Joined
·
6 Posts
Are you sure it's the power steering, the sound wasn't terribly clear on your video, but I would bet dollars to donuts it is the alternator crapping out. Mine just did last week, I was chasing a whining noise around for days, sounded like motor static on an AM radio, finally figured it out when the battery light illuminated on the second day, I swore the sound was coming from the drivers side, but the way the alternator is bolted to the front cover the sound resonates.
21339

Because I am a cheap bastard I went to the U pull it yard and got an 805AD off of a 2010, $30. Didn't realize they had changed the plug in 08 so had to go back for one, but used my drill and wire wheel to remove all of the patina then put a clear coat on it. Works great and saved $120, just changed the power steering fluid tonight.

Any ideas on what to do next?
[/QUOTE]
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Are you sure it's the power steering, the sound wasn't terribly clear on your video, but I would bet dollars to donuts it is the alternator crapping out. Mine just did last week, I was chasing a whining noise around for days, sounded like motor static on an AM radio, finally figured it out when the battery light illuminated on the second day, I swore the sound was coming from the drivers side, but the way the alternator is bolted to the front cover the sound resonates. View attachment 21339
Because I am a cheap bastard I went to the U pull it yard and got an 805AD off of a 2010, $30. Didn't realize they had changed the plug in 08 so had to go back for one, but used my drill and wire wheel to remove all of the patina then put a clear coat on it. Works great and saved $120, just changed the power steering fluid tonight.

Any ideas on what to do next?
[/QUOTE]
Actually, I didn't realize it at first but there are 2 whining noises that you can hear. The power steering has a low whine but the supercharger noise only happens when it's warm.

Also my radio stopped working. Fog lights never did. From what I read these cars start having electrical gremlins when the voltage isn't perfect.

I found a TSB for oil squirters that explains that loud whining. I'll upload a video of it running cold. Either way I'm still replacing the alternator and the rest of the power steering lines. If it's not oil squirters, I hope it's the alternator. I'll update when I throw more parts at it.
 

·
Registered
Joined
·
504 Posts
13.6 volt is the bare minimum for an alternator, it might be a sign it's going bad. Look up google for ways to test it.
 
1 - 5 of 5 Posts
Top